Posts tagged: best practices

JAVA : Statistics Class

Another name for it would be Counter class.

How many times you did this ?

int databaseUpdateCounter=0;
.
{
.
     databaseUpdateCounter++;
.
}
.
.
System.out.println( "databaseUpdateCounter"+ databaseUpdateCounter);

you only need to follow up on the count of a certain operation.

And then you needed to count something else, and kept on adding counterVariables ?!

Read more »